Search the Community

Showing results for tags 'echo server'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Test and Measurement
    • Measurement Computing (MCC)
    • Add-on Boards
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions
    • Archived

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 5 results

  1. Hello, I have been successful in running the lwIP echo server on the Zybo Z7 board. However, I want to develop a web server on Zynq. I have gone through the lwIP documentation. However, in the discussion of this topic, I was successful in reading the .bin file from the SD card. Now I want to set up a web server on Zynq so I can command the server to read the .bin file from SD card and store it in the DDR. How do I start working on the web server. I have been searching a lot for the tutorial or anything that could make me understand in a simpler way but I failed to find any.! I also tried understanding the echo server C code in sdk however, after a point it seems too confusing to me. I could even think of modifying the echo server C code to develop a web server with some help, may be. The documentation of lwIP is confusing to me at this point.... Thanks, Shyama.
  2. Hi, I followed the instruction in https://reference.digilentinc.com/learn/programmable-logic/tutorials/nexys-video-getting-started-with-microblaze-servers/start carefully to create the simple echo server with Nexys video board. The vivado version is 16.2. The Ethernet licence is evaluation version. After creating echo server application and run with SDK , it does not run as expected, the output is as follows: -----lwIP TCP echo server ------ TCP packets sent to port 6001 will be echoed back WARNING: Not a Marvell or TI Ethernet PHY. Please verify the initialization sequence link speed: 100 It seems to me the physical interface on the board is not configured right. I tried other lwip application, there is the same problem, so I don't think it is the problem of software or bsp setting. Could you help me ? Thank you very much! Cynthia
  3. Hi I want to utilize sdk to test echo server lwip,fpga program and run configration are done.However,in console,there are some lines make me confused. -----lwIP TCP echo server ------ TCP packets sent to port 6001 will be echoed back link speed: 1000 DHCP Timeout Configuring default IP of 192.168.1.10 Board IP: 192.168.1.10 Netmask : 255.255.255.0 Gateway : 192.168.1.1 TCP echo server started @ port 7 When I ping the board on PC,it displays "can't access the destination host" My board is Zybo.The hardware been built in vivado 2014.3.1 is a Zynq7 System Processing Core.What makes wrongs? Regards, Sophia
  4. I setup my Nexys Video for the first time, and tried to setup an echo server using Vivado/SDK. I followed the following tutorial: https://reference.digilentinc.com/learn/programmable-logic/tutorials/nexys-video-getting-started-with-microblaze-servers/start When I go to generate a bitstream, I get the following error: [Common 17-69] Command Failed: This design contains one or more cells for which bitstream generation is not permitted: design_1_i/axi_ethernet_0_U0_mac_U0/tri_mode_ethernet_mac_i/bd_929b_mac_0_tri_mode_ethernet_mac_v9_0_12) If a new IP Core license was added, in order for the new license to be picked up, the current netlist needs to be updated by resetting and re-generating the IP output products before bitstream generation. The Nexys Video kit did not ship with a special Vivado license, am I required to purchase a license in order to use the Ethernet interface of my board?
  5. Hello, I am running Vivado 18.1 and would like to try to get the echo server running by following this demo. I understand that the demo hasn't been verified on Vivado 18.1, but nevertheless I would like to try it. The only problem is that my block diagram doesn't quite match what is displayed on the demo screen shots, even though I have double checked the steps to create it. Is there a bd tcl file available to recreate this diagram for the demo. If not, can a higher resolution picture of the completed diagram be posted?