Search the Community

Showing results for tags 'basys2'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Test and Measurement
    • Measurement Computing (MCC)
    • Add-on Boards
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions
    • Archived

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. This is my first time writing. I'm using openSUSE Leap 15.3 (64bit) and 15.4 (64bit), Xilinx ISE 14.7, Basys2. The installation procedure for Xilinx ISE 14.7 is based on openSUSE Leap 42.1 (64bit) at the URL shown below. http://www.blunk-electronic.de/ise/howto_install_ISE_on_SuSE.pdf (based on "ISE Installation on OpenSuSE Linux Leap 42.1 (64bit)") In addition, I also have the latest "Adept Runtime", "Adept Utility", "libCseDigilent" installed. lsusb # Output Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 005 Device 004: ID 1443:0007 Digilent Development board JTAG Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 003: ID 062a:4102 MosArt Semiconductor Corp. Wireless Mouse Bus 001 Device 002: ID 1a81:1004 Holtek Semiconductor, Inc. Wireless Dongle 2.4 GHZ HT82D40REW Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub When I start iMPACT and run "Initialize Chain", I get the error shown below. On iMPACT, writing is not possible. GUI --- Auto connect to cable... AutoDetecting cable. Please wait. *** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates PROGRESS_START - Starting Operation. Using windrvr6 driver. Connecting to cable (Usb Port - USB21). Checking cable driver. File version of /opt/Xilinx/14.7/ISE_DS/ISE/bin/lin64/xusbdfwu.hex = 1030. File version of /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex = 1030. libusb-driver.so version: 2022-06-17 11:19:34. Cable connection failed. Connecting to cable (Parallel Port - parport0). libusb-driver.so version: 2022-06-17 11:19:34. parport0: parport1: parport2: parport3: LPT1 Base Address set from env variable = 0. LPT base address = 0000h. LPT1 Ecp Address set from env variable = 400. ECP base address = 0400h. LPT port is already in use. rc = FFFFFFFFh Cable connection failed. Connecting to cable (Parallel Port - parport1). libusb-driver.so version: 2022-06-17 11:19:34. LPT2 Base Address set from env variable = 10. LPT base address = 0010h. LPT2 Ecp Address set from env variable = 410. ECP base address = 0410h. LPT port is already in use. rc = FFFFFFFFh Cable connection failed. Connecting to cable (Parallel Port - parport2). libusb-driver.so version: 2022-06-17 11:19:34. LPT3 Base Address set from env variable = 20. LPT base address = 0020h. LPT3 Ecp Address set from env variable = 420. ECP base address = 0420h. LPT port is already in use. rc = FFFFFFFFh Cable connection failed. Connecting to cable (Parallel Port - parport3). libusb-driver.so version: 2022-06-17 11:19:34. LPT4 Base Address set from env variable = 30. LPT base address = 0030h. LPT4 Ecp Address set from env variable = 430. ECP base address = 0430h. LPT port is already in use. rc = FFFFFFFFh Cable connection failed. PROGRESS_END - End Operation. Elapsed time = 2 sec. Cable autodetection failed. WARNING:iMPACT:923 - Can not find cable, check cable setup ! In the cable setup, select "Digilent JTAG USB" radio button, [Port:] pull-down shows nothing, as shown in the image. However, "dadutil", "djtgcfg" command are working properly and these commands (CUI) can write. djtgcfg enum # Output Found 1 device(s) Device: Basys2 Device Transport Type: 00010001 (USB) Product Name: Digilent Basys2-100 User Name: Basys2 Serial Number: 210155473605 djtgcfg init -d Basys2 # Output Initializing scan chain... Found Device ID: d5045093 Found Device ID: 11c10093 Found 2 device(s): Device 0: XC3S100E Device 1: XCF02S dadutil showinfo -d Basys2 # Output Product Name: Digilent Basys2-100 User Name: Basys2 Serial Number: 210155473605 Product ID: 00800122 Firmware Version: 0116 Device Transport Type: 00010001 (Transport Type = USB, Protocol = 1) Device Capabilities: 00000005 DJTG - JTAG scan chain access DEPP - Asynchronous Parallel Input/Output Can't I use Basys2 with iMPACT on Linux? Or is there some setting that is missing? Thank you in advance for your response.
  2. 2021-12-21 I am stuck trying to get an environment that I can use for basys2 and verilog. I have successfully done this for basys3. For basys2 I have vivado 2017.2 (stated in an appendix of a book) but cannot configure it to use basys2 ) . Could someone give me some help to get started with basys2. ( I can use vivado 2019.1 successfully for basys3 after copying board files but am completely stopped with basys2. My problem is not with verilog but getting over a very elementary problem of getting and configuring the proper files needed for basys2. Are there any board files required for basys2 (I think there must be but I cannot find them nor can I find instructions for where they go ) The tutorial for basys3 was sufficient to get me started but not the tutorial for basys2.
  3. Hello, I need help on a Basys2 board, that show incompresible characters when Adept runs at begin. Then I get this when it Initialize Chain (see below). You can see the error on attached file. The board is from an school laboratory and it is use by many students, so nobody know what happend to get this status in the board. ===== Digilent Adept ===== Adept System Rev 2.7 Adept Runtime Rev 2.19 Adept Application Rev 2.4.2 Copyright © 2010 Loading board information... Initializing Scan Chain... Board information loaded. Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Found device ID: ffffffff Initialization Failed. Regards Luis